JV-LinkDirectory 4.8 Dev Update: JV-LD 4.8+ will require atleast MooTools version 1.2.5

We are now gearing up for the next release of JV-LinkDirectory (version 4.8), which will use modified calls to mootools library.

Before we get into the requirements for JV-LD, lets take a look at what Joomla! offers by default:

  • Joomla 1.5.x versions include MooTools 1.11.
  • Joomla! 1.5.19+ versions have a “System – MooTools Upgrade” plugin, which when enabled, provide MooTools Core 1.2.5 support.
  • Joomla 1.6.0 and newer include MooTools 1.3
  • Joomla 1.7.0 and newer include MooTools 1.3.2

Many old functions have been removed or renamed in Mootools 1.3. Thanks to the compatibility module they still work fine in Joomla 1.6, however a future version of Joomla is likely to remove the compatibility module.

What about JV-LinkDirectory?

From JV-LinkDirectory version 4.8 onwards, mootools 1.2.5 will be a minimum requirement. This means that, JV-LD 4.8+ should work on Joomla! 1.6.x and 1.7.x by default.

For Joomla! 1.5 versions, you must enable the “System – Mootools Upgrade” plugin to get it working. If you are using extensions on your Joomla! 1.5 website, that need mootools version less than 1.2.5, then its time, you talk to the respective developers and get them upgraded to use mootools 1.2.5 at least.