JV-Relatives 5.7.1

Product downloads of JV-Relatives 5.7.1 version for Joomla 3.x. Please note that this version works only on Joomla 3.x versions and not on Joomla 1.5/2.5 versions.

Download the release now!