JV-Relatives is now Joomla 2.5 ready!

We are happy to announce the compatibility of JV-Relatives with Joomla 2.5 today. We have also released a new version of JV-Relatives that will work for Joomla 1.6, 1.7 and 2.5. If you are using JV-Relatives on Joomla 1.7, then please upgrade the plugin alone, as there is no change to component code.

Hope you enjoy this new version of JV-Relatives. If you are happy with our product, then you may please vote for it and write a review at http://extensions.joomla.org/extensions/news-display/articles-display/related-items/4500